HELP! Don't work animation GITF

I export GITF for three js my model with animation, but it exporting without animation.

This my scene with gitf file:

I can not access the file :frowning: but if the file exports within three without animations, you should ask pn their forum.

Ops sorry, gave acces to the file

If you try in another viewer like the gltf sample viewer and the animations are in it would definitely be on us.

I tried 2 viewer, sandbox.babylonjs and gltf-viewer.donmccurd
there is no animation either there or there

So it sounds like it is an export issue and you should check with them as we are only maintaining the babylon exporters.

So i used babylon exporter.

Ohhhh i start to better understand :slight_smile: you are using the babylon exporter to use the model in three ?
We would need more info about what you are trying to export and is it from maya, max, blender or javascript ?

Then @Drigax or @Guillaume_Pelletier might be able to help.

Yes, i use babylon exporter for using model with anim. in trhee js.
Exporting from 3ds max
In zip archive my 3ds max scene with model.

I tried all check boxes in exporter)
Made animation group, but animation dont appear

Great @Guillaume_Pelletier might be able to help

Hello, i have animation exported but only the sphere are moving up and down. How to you make other part moving, are you using morph? i do not see any morh Modifier attached to any mesh.

Yes, only sphere animation there.
I used morher and than converted animation to mesh via scripts.

Hello, so it can be solve?

Hi, i will have a closer look on it tomorrow. I’ll keep you posted.

1 Like

Thank you very much!

1 Like