Guys when i export Animation as FBX its working but


#1

Guys Hello,
I m new .
i read the 3DSMax to glTF - Babylon.js Documentation
but when i export small things it work with animation but
i m trying with that it wont work
Guys can you tell me whats the problem

https://drive.google.com/file/d/16bluxxefKEgsNmQIcEtA0t4aQ2Ze5STs/view?usp=sharing


#2

@PatrickRyan @kcoley Can you help?


#3

Sure, I’ll try to dig into it later today. I took a short look last night and I was able to get it to work in .babylon file format, but not glTF.


#4

Same. The mesh animates with Babylon, but there is no animation data being written to the file when exporting out of Max to glTF.

@Simon_Jamil, another thing to keep in mind with the glTF format is when you share out the files, or move them around in your own organization system, you need to keep the .bin file and the .glTF file together, along with any textures you export. The bin file is the actual mesh, so without that the glTF is unusable. Another option if you don’t want to keep track of all the extra files is to export as a glb file which is a packed binary file that contains the json, the mesh, and textures in one file. It’s much easier to store and share that way.

Another tool you should grab is the glTF shell extension that @bghgary wrote which allows you to get a right-click contextual menu in the file explorer to pack a glTF into a glb or expand a glb into a glTF. That way if you need to look at the textures or json of a glb, you can unpack it and have direct access.


#5

@Simon_Jamil, I was able to get the animations to export for glTF, though looks like the exporter expects them to be collected under an animation group manually:

  1. Select the mesh in viewport with the animations
  2. Right-click the viewport and select “Babylon Animation Groups”
  3. Select "Animation (0, 100) on the left (this will be one of the exported animation groups)
  4. Select “Add Viewport Selection” to add the selected mesh animations under the same animation group (from step 1)
  5. Select “Confirm” to confirm the selection

    Afterwards, you can try exporting again, and the animation should now work in glTF, which I included in the zip archive:
    testAnimGroup.zip (62.6 KB)

This contains the glTF and .bin file. As @PatrickRyan mentioned, you could also export as glb to just deal with one file:
testGLB.zip (62.6 KB)


#6

Thanks A lot Guys …
its worked perfectly