How to build and compile new JS files after modifying the source code

Can you send me your download link to try it out?

to try what out exactly?

Thank you for always answering my questions! I want to try to see if the babylonjs package you gave can be compiled successfully through the steps of npm install → npm run build:babylonjs.
I don’t know what the problem is either, I’m at a loss.

it is very hard for me to understand, as all developers in the team (and others), our CI, all use those functions successfully. I believe you there is an issue, but I can’t reproduce it.
If you have the npm logs, and some more information I can work with, I might be able tohelp and fix this. I know I suggested it already, but re-cloning (completely deleting the directory on your hard drive before), and then running npm install should be successful. If it isn’t, there is an issue in the environment (node version, npm version, os, version), though it does feel odd that you get it and others don’t.

@RaananW
It might be worth putting a .npmrc file at the root of the repo with prefer-offline=false and legacy-peer-deps=false , incase the user has different global configs

Also, there is an easy way to solve the no types before first compile issue, which is to set “types”: “./src” in all the dev package.jsons. Theres another way to do it with tsc version override in package.json too, but types src is easy and works fine. It also has the benefit that highlighting an identifier and hitting f12 in vscode takes you straight to the source implementation instead of a .d.ts file.

@wangyu1512cn
Do you have a .npmrc file in your home user directory?

Also, does anyone know if there are inconsistencies between us / china npm cdn?

There is no global tsc (as i asked earlier), so this is probably not an issue. Also - the user is not necessarily coming from china. Having said that - we have other community members from china who haven’t reported any issue. Of course I don’t want to rule this out, but without a proper log it will be hard to tell what the issue is.

I don’t mind adding a .npmrc file, not sure if it will solve this issue here. The user can add one and tell me if that helped.

I run successfully with inter CPU.
thank you !

I run successfully with inter CPU.
before use amd cpu.
thank you !

Do you mean we have an issue in the repo with people using AMD processors? Oh no…

Can anyone with an AMD processor reproduce this?

On the other hand, I am happy you have solved the issue :slight_smile:

Works fine for me on AMD Ryzen 5 3500U (Windows 10). Fresh install, followed the exact steps in the video. Result: Successful compilation, no errors.

1 Like