Import .obj-file from Blender export is inverted?

I’m currently exporting this scene from blender as .obj with default export options:

When importing the .obj-file into babylon it is inverted at the Z-Axis. But importing back to blender works fine. It’s fine because the default option are:

However blender still shows it as positive Z… So basically blender/babylon show it inverted because idk why. So i thougth ok with “Forward: +Z” it should be fine in babylon. But then the Letters on the Cube are in different directions, especially “Z” (not only mirrored by Z it’s rotating around Z)

So my only work around is to export it by default values and while importing i add the scaling vector (1,1,-1)
Is this the fault of blender or babylon?

Not the fault of either, unfortunately there are plenty of conventions and no one way only.

You have a few options on the loader itself to invert like OBJFileLoader | Babylon.js Documentation

You could also try the gltf exporter ?

1 Like

Yeah it’s true. There are many different conventions and still small things are made different by whoever tries to accomplish the conventions…

I’m good for now. It works by adding that scaling vector…

Gltf is also inverted differently i also there rotate the meshes while import…

It works so far so it’s good. Just wondering why there are specifications and still it kinda is different everywhere.

The matter is that OBJ format still has no specification - only some conventions :slight_smile:
On the contrary, GLTF/GLB format has fully developed specification - glTF™ 2.0 Specification

You may play with Y Up parameter in Blender when exporting GLTF:


I did. nah i actually don’t think the mistake is made by babylon or blender.

The Original file is made by FreeCAD and that one is exported by gltf, i think they somehow messed that up and since then my blender file is also messed up