indexDB Cache problem

Happy New Year, I have a problem with babylon5.22.1. Why does Babylon5.22.1 add a timestamp to the indexDB cache request? After the timestamp is added, I cannot get the cached resource (the source file is in database.ts private _saveFileAsync).

Welcome aboard!

Maybe @sebavan or @RaananW will know but be patient as it is vacation time these days.

just back in action, i’ll make sure to check that soon. Thanks for the patience!

Are you talking about the request to the manifest?

yes,The blob request address when accessing the indexDB cache,change the source code after normal use

The timestamp was added almost 2 years ago.
Can you reproduce the issue and show what exactly you mean? I am not 100% sure what you mean with blob URL as well in that case…

eg: indexdb key “blob:http://localhost:3100/00020cef-a5bd-491c-8d83-85497ff7764f”, babylon Enable cache, will access blob:http://localhost:3100/00020cef-a5bd-491c-8d83-85497ff7764f?=1672879426839, Unable to access, remove the timestamp normal access

blobs should not be cached by indexedDB, they are auto-generated by the gltf loader (which i assume you are using in this case). If it does try to access the blob through indexeddb we need to fix that. can you reproduce this on the playground?

Still waiting for a reproduction, if possible. Whenever you can! please ping me when you do.

Thanks a lot! :slight_smile: