Issue : animation - goToFrame

I have tried to move model animation to the specific frame using the go to frame method

But it seems to be weird
it is not worked at first and after that, when I try again, it is worked well

the same thing has happened on the sandbox of babylonjs

I want to resolve this issue with PR
is anyone know about it ??

Would you have a PG to share. I’m not sure to understand the part

Your method might just not be the right one (or else it could be a bug). Without a PG can’t tell…

even at this moment, it happen on the sandbox of babylonjs

I can share some videos with you

look at the animation progress bar carefully
even though I click the specific frame to go to that frame, it is ignored

cc @Cedric


Can you please share the file and the original scene from your dcc so we can check the export as well ?

Here is a repro:
Babylon.js - AnimatedMorphSphere.gltf (

  1. Open the link.
  2. Pause the animation.
  3. Click somewhere else in the animation.
  4. Click Play.

Result: See video above. The animation jumps back to where it was instead of the new position.
Expected: The animation to play where it was clicked

Definitely looks like a bug.

The below answer is completely the same thing that I want to say

I’m taking a closer look.

I’m a bit busy at the moment. I’ll do my best to dig more in the coming days.


I’ll post this issue on babylonjs Repo, thanks

Look forward to resolve this issue.
It is critical to UX of 3D animation content.

Yes, this issue is still on my radar. ETA today or tomorrow.

1 Like


1 Like