Issue with iOS version 17.4.1

Hey, I have a scene which works great in any environment except iOS 17.4.1, even with iOS 17.3 it seems to work.
I was able to reproduce it in this playground on my iPad:

I tried to disable WebGL2 and UBO but the same result, it takes a little bit more to crash but it is still crashing,

It happens if we go multiple times between view1 and view2, suddenly we lose the context :frowning:
I have a log file as well, if it helps, it is quite long because of this I saved it in a file.
log.zip (2.6 KB)
Any ideas are welcome

Thanks for providing the Playgrounds! I tried the first one on my iPhone SE (17.4.1) and could not repro the issue. What model is your iPad? Guessing it has less graphics memory than my device.

@Evgeni_Popov, @sebavan, any thoughts? The first error in the attached log is:
ERRORBJS - [20:09:18]: Error: Something went wrong while creating a gl vertex shader object. gl error=37442, gl isContextLost=true, _contextWasLost=false

1 Like

I just tested on my iPhone SE, iOS 17.4.1 (your first PG), and could not make it crash even after 40+ switch between view1/view2…

Note that I have this error on my desktop:

image

Perhaps it has something to do with the problem you’re experiencing…

1 Like

Hi, yes, it is an old model, Ipad air 4.
If I use the model with png/ jpg textures then yes I got an error about memory limit, but with ktx I think it is a different error, or atleast it is saying nothing about memory :frowning_face:

Sorry, it is because some texture dimensions are not divisible by 4.
Can you try this

or even directly here
Thanks

Yes, this PG does not generate the error in the console log, and it still works for me…

1 Like

Same (again on my iPhone SE) :confused:

1 Like

I am already on 17.5

Understood :pleading_face:
Can you please try on the server as well? There are not too mucb differences, just some cookie & analytics script. Thanks

17.4.1, server and playground working as expected.