KTX texture issue for skybox

I figured I’d post another question since I’m not sure if posting a reply on an old forum thread would get very much attention. So…sorry for resurrecting a long-old thread (KTX texture problem - #22 by Deltakosh), but I’m not sure if it was ever figured out how to format the CubeTexture creation code to use KTX textures?

When I use:

var available = [’-astc.ktx’, ‘-dxt.ktx’, ‘-pvrtc.ktx’, ‘-etc2.ktx’, ‘-etc1.ktx’];
var formatUsed = this.engine.setTextureFormatToUse(available);

The skybox still does not show up with:

skyboxMaterial.reflectionTexture = new CubeTexture(https://our-bucket.s3.amazonaws.com/skybox_textures/generic/skybox, this.scene);

despite the fact that my file directory looks like:

^ I also had skybox-dxt.ktx first named as skybox.ktx. Neither of these names worked.

This works:

This does not work:

I think I understood what the thread was saying about how the ‘new CubeTexture’ function does not work with ktx (?), but was an alternative for skybox generation figured out?

adding @Evgeni_Popov

This topic is a duplication, I’ve solved the issue here KTX texture problem - #24 by Vinc3r