Maya export to GLB crash - Double UV set. Quick hotfix?

Hi guys, very new to Babylon & super excited to discover all these wonderful functionalities.

After two successful export, I started to be quite confident…
Yet, I’ve been stuck for hours on trying to fix a model from 3ds max a freelancer exported to me as an FBX…
All looks lovely on Maya, low poly & textures well linked, and yet the model loads white…

The error message I receive in orange says my material has UV1 & UV2 and only one can be supported.
Therefore I decided to find this evil UV & delete it … But it turns out its ‘‘map1’’ the ‘‘default’’ UV set of Maya, which seems not to be delectable.

Any ideas on how to fix this easily (without redoing the whole mapping on the default layer) and finally export my lovely .GLB?
I’m a little out of breath and feel like the only thing I haven’t tried yet is to install 3dsmax… xD

Thanks a million to whoever has a good idea!

Adding @bghgary for guidance.

glTF (.glb) files support 2 UV sets, so not sure why you’re getting that error.

I’ve used multiple UV sets through the Blender to glTF exporter without any issue, so it seems like something might be goofy in the export?

Would you be able to share that FBX possibly?

cc @Drigax who will be back on Tuesday.

Thanks for your answer guys, much appreciate it!

If you don’t mind I’d rather avoid putting the fbx on a public forum, is there an email address I can forward it to?

Uploading here the error message concerning the two UV. (The orange line I guess?)
I also tried to use 3ds max to export but it seems to crash without warnings.

Best & have a lovely end of weekend!

Alright guys, sorry I bothered you, managed to fix it.
In the end it was just on the account of my too little experience of AR.

But following step by step all docs I could find (and mainly, sticking with PBS materials) how to fix it & UV weren’t the issue here.
Replacing parts by CAD files (not especially high poly therefore I thought it’d work) weirdly turns out not rendering properly & puts a default shiny metallic material instead of the assigned one.
Still haven’t managed to fix this so … I just literally re-modeled the whole parts.
But if you know a quick way to make CAD file ready for GLB export, I’m all ears!

Thanks for your prompts answers, it was a much appreciated psychological support :slight_smile: