Monoco Edtior is not letting me build or npm run start?

This just started happening out of nowhere to me, I was able to run start and build yesterday no problem. The only thing I did this morning was a git pull upstream master then when I tried to kick up my server this started happening.

ERROR in [at-loader] ..\..\Playground\src\tools\monacoManager.ts:13:109 
    TS2694: Namespace '"F:/gitHUB/Babylon.js/Playground/node_modules/monaco-editor/esm/vs/editor/editor.api".editor' has no exported member 'IStandaloneEditorConstructionOptions'.
Child vs/editor/editor:

So I went back and did everything from square 1. npm install checked that everything was correct, npm run build and I get some odd error about HTML elements and duplicate declerations.

Super confused.

Here is the build error:

[10:57:53] 'buildes6' errored after 19 s
[10:57:53] Error: TSC Failed.
    at formatError (C:\Users\pryme\AppData\Roaming\npm\node_modules\gulp-cli\lib\versioned\^4.0.0\format-error.js:21:10)
    at Gulp.<anonymous> (C:\Users\pryme\AppData\Roaming\npm\node_modules\gulp-cli\lib\versioned\^4.0.0\log\events.js:33:15)
    at Gulp.emit (events.js:201:15)
    at Gulp.EventEmitter.emit (domain.js:471:20)
    at Object.error (F:\gitHUB\Babylon.js\node_modules\undertaker\lib\helpers\createExtensions.js:61:10)
    at handler (F:\gitHUB\Babylon.js\node_modules\now-and-later\lib\mapSeries.js:47:14)
    at f (F:\gitHUB\Babylon.js\node_modules\once\once.js:25:25)
    at f (F:\gitHUB\Babylon.js\node_modules\once\once.js:25:25)
    at tryCatch (F:\gitHUB\Babylon.js\node_modules\async-done\index.js:24:15)
    at done (F:\gitHUB\Babylon.js\node_modules\async-done\index.js:40:12)
    at F:\gitHUB\Babylon.js\Tools\Gulp\tasks\gulpTasks-librariesES6.js:219:13
    at F:\gitHUB\Babylon.js\node_modules\shelljs\src\exec.js:127:9
    at ChildProcess.exithandler (child_process.js:311:5)
    at ChildProcess.emit (events.js:196:13)
    at ChildProcess.EventEmitter.emit (domain.js:494:23)
    at maybeClose (internal/child_process.js:1000:16)

It just sucks because it gets through the majority of the build then starts drops this after lines and lines of this stuff:

./node_modules/@types/react/index.d.ts(2683,14): error TS2300: Duplicate identifier 'LibraryManagedAttributes'.
../../../node_modules/@types/react/index.d.ts(2949,14): error TS2300: Duplicate identifier 'LibraryManagedAttributes'.
../../../node_modules/@types/react/index.d.ts(2962,13): error TS2717: Subsequent property declarations must have the same type.  Property 'a' must be of type 'DetailedHTMLProps<AnchorHTMLAttributes<HTMLAnchorElement>, HTMLAnchorElement>', but here has type 'DetailedHTMLProps<AnchorHTMLAttributes<HTMLAnchorElement>, HTMLAnchorElement>'.

Even on a brand new branch based off the master and following every step here Start Contributing to Babylon.js - Babylon.js Documentation

I still get the error, is this only me or is anyone else getting this after trying to build on a fresh branch and after all the correct steps?

At some point my global gulp got (ggg) corrupt, working in one of my other projects.

After a long day of trying everything in the book, a

npm install -g --force gulp@4.0.0

saved the day <- think

1 Like

I am about to scream or cry or I dont even know at this point, no this did not fix it.

I spend more effword time messing with npm run start npm build then anything else throughout my day while trying to contribute.

Start from square 1 do a fresh install of npm, a new clone, a new branch follow all the contribution guide steps super carefully (for the f#^%$J%RKL thousandth time).

Im about to just toss this crap out and give up. I just want to program I dont wan to sit looking at a command line all day everyday getting nothing done looking at stupid errors that dont tell me shit.

The solution ended up being deleting everything. Throwing my CPU out the window and choosing a new profession… not really but it did include deleting everything my NPM all my app data associated with node_modules. Basically had to to back to pre step 1 and then just copy and pasting my stuff over to a new branch because if I tried to go back to my old one crazy errors would happen again that had nothing to do with my code.

You needed to delete the node_modules folder in the playground folder only I ll see if I can automate it.

ohh my, I went through hell and back trying to get my branch to work again… if that is what the issue was I am going to laugh.

So much better than all of the other options!