"Optimize Vertices" Option Breaks Latest Version of Maya Exporter (20200917.1)

With the latest version of the Maya Exporter in Maya 2019, if I have “Optimize Vertices” checked, every piece of geometry emits the error below during export, and in the GLTF it just ends up as a dummy node with no geometry. This wasn’t the case in the previous version of the exporter I was using (20200721.1). Without “Optimize Vertices” the export ends up being more than 5x as large in terms of file size.

To repro, just create a simple primitive in Maya 2019 and use the babylon exporter to create a gltf with “optimize vertices” turned on. Is anyone able to look into this?

I’m also wondering, does anyone know how I can revert to a previous version of the exporter? The Installer pulls down the latest version by default, and replacing the dll’s and .mel files directly leads to the plugin not loading :frowning:

pCylinder2
	no morph targets
	mFnMesh.fullPathName=|pCylinder2|pCylinderShape2
	Exception raised during export. Node will be exported as dummy node. 

Message:
Object reference not set to an instance of an object.

yes, same here. checking on “optimize vertices” option does creates a dummy node with no geometry.

Ok please create an issue on the repo with a repro file :wink:

@Deltakosh looks like someone already added it: Maya Plugin - September 17 release · Issue #874 · BabylonJS/Exporters · GitHub. I added a comment and can add a repro file also, though any Maya file with geometry has this issue.

2 Likes

Just downloaded the latest exporter and this is still an issue (10/13/20). Works just fine if you don’t optimize verts but i like the sound of “optimize” and so badly want to check that box :slight_smile:

1 Like

Hi! Any update on this issue? I noticed it not clicking the “Optimize Vert” option adds roughly 2 MB to my assets. Thanks.

adding @Guillaume_Pelletier

1 Like