PBRCustomMaterial breaks naming conventions?

Several non-static members of PBRCustomMaterial seem to be breaking Babylon’s naming conventions by using PascalCasing instead of camelCasing. I guess the goal is to group them together at the beginning of the property and method lists to make them easier to find, but it seems a common prefix would group them together without the confusion of breaking Babylon’s naming convention? And I guess it’s too late to fix/change the naming convention used for this class, so it’s more of a suggestion/consideration for future classes that aren’t in use yet…

PS, the custom material classes look really awesome, the naming just confuses me a bit. :slightly_smiling_face:

Yup for back compat purpose it can not be changed now and the material is also a community one :slight_smile:

Nevertheless, fully noted :slight_smile:

1 Like