Require extension CVTOOLS_babylon_mesh is not available

I have an error loading a gltf file:

Require extension CVTOOLS_babylon_mesh is not available

I guess I’m missing a file, but which js file, but which one would it be?



Hello is it in the context of Unity toolkit? Can you provide more info?

1 Like

Hi @Deltakosh, yes using Unity Toolkit export. I tried to load the generated model in “clean” project, but get that error. If I try to load that one in sandbox I get the same error. It does load in project generated by toolkit.

Adding @MackeyK24

The error is telling you that you dont have the required extension (which are in babylon.manager.js)

If you wanna use the raw geometry only in a project without babylon.manager.js then you need to select these options:

  • Primitives instead of sub meshes
  • Right handed instead of left handed
  • And disable Unity Metadata

Note: You will only get RAW GEOMETRY including any materials and animations… Nothing else that babylon.manager.js provides like shadows, lightmaps, reflection probes, script components, etc…

Thanks Mackie, so as I understand I would need to import babylon.manager.js, currently need to use 4.20 as there are some input problems in Babylon 5. Is it backwards compatible?

I also saw there seems to be bindings for photon and socket, can’t find information on documentation, is it a to-be-enabled in the future, or how can I use it?

The Socket.IO and Photon Engine options are there to basically LOAD the javascript library on the host page as well as .d.ts files are in the project. You would just code up your networking using either library.

Or you say no networking lib and provide another networking solution

Hey, sorry to up this thread but i have kind of the same issue, i’ve just installed the new release (V5.0.0-A12) on a fresh new unity project and scene Exporter show the same missing extensions (CVTOOLS_babylon_mesh and CVTOOLS_left_handed).
But the babylon.manager.js is already present on assets/[Babylon]/Template/Scripts, so i don’t figure out what to do next.
What did i miss here ?


You basically need the babylon.manager.js loaded on your host page. When you enable web project for the export… i create an engine.html by default… look at that page in your export folder to get an idea of what is going on the host page.

I made a little tutorial on baking lightmaps… but i create the whole project from scratch

Hey guys, i made a tutorial on lightmaps. Check it out, it goes into baking light for large detailed scenes


Works like a charm, thanks @MackeyK24 for your quick answer !


Hey @MackeyK24 I’m very new to all this and am running into the same problem and I can’t load your video. Is there any chance I could be shown how to solve this issue and have lightmaps working?

when load the manager.js will get this error…

Uncaught TypeError: e.RegisterClass is not a function
at babylon.manager.js:6:13592
at babylon.manager.js:6:30895

cc @MackeyK24

What version you using… Babylon has changes (a few versions ago) that got rid of RegisterClass… i think it uses RegisterTypes now… But i thought i fixed that in the later versions of BJS… Try the last alpha version UnityExporter/Redist/Alpha at master · BabylonJS/UnityExporter · GitHub

I use the lastest version…and use manager.js on git “UnityExporter/Manager/babylon.manager.js”, that one still use “RegisterClass” function.

emm…when i update babylon to v5, it fixed !
but got new errors…

Cannot read properties of undefined (reading ‘SceneController’)
at Function.n.InstantiateClass (babylon.manager.js:5:21250)
at babylon.manager.js:7:14554
at Array.forEach ()
at Function.n.DoProcessPendingScripts (babylon.manager.js:7:14432)
at n.postProcessSceneComponents (babylon.manager.js:7:10237)
at Function.n.PostParseSceneComponents (babylon.manager.js:5:15520)

Did you try this version of the Toolkit here

UnityExporter/Redist/Alpha at master · BabylonJS/UnityExporter · GitHub

(is packaged with babylon.manager.js… no need to get from UnityExporter/Manager folder)

yes i use this version.
and if add ‘BBL_Export.js’ to my html page , the error was fixed, so what is the right work flow? i use SceneLoader.Append(“scenes/”,“SampleScene.gltf”,…) to load it now.

btw, the video [ Getting Started Video] is not found.

Yeah … sorry… i screwed that one up. Accidentally deleted that when making my new website and did not have a backup of that video.

When i get time (and a stable PRO TOOLS EDITION up and running) i will make a new one… Sorry :frowning: