Running BabylonJS WebXR on Oculus from PC

Hello,

I don’t know if this is a silly question, but I have googled for 2 hours and can’t find a clear answer.

I would like to run a BabylonJS WebXR app on Oculus quest 2, however, for performance reasons I don’t want to run it from the native Oculus browser, but from a browser on my PC. Is this possible, and if so, how?

I tried running Chrome and Firefox on the PC through Oculus Link, but when I click on VR mode, the browser just shows a split view of the scene, instead of going into full VR mode.

Thanks

cc @RaananW

oculus link should work just like any other headset connected to your desktop. I am not sure about firefox, but chrome does work corectly with oculus link.

Can you share the experience you are trying to load? are you sure it is a webxr (ant not a webvr) scene?
split screen i the legacy behavior (or fallback) of the vr experience helper, in case it cant find a VR device. There should be a fallback to XR, bu the best would always be to use the XR default experience directly.

Had excactly the same problems and was looking for a good dev experience…
This is not what you asked for, but maybe check this “alternative”: :sweat_smile:

You can host a local https server and just run the localhost in the oculus browser to test your code.
It’s way more easy if you use the babylon.js editor for this…
How to run https server on Babylon.js Editor - #18 by Limes2018

Of course I am still curious for a real solution for your question :nerd_face:

2 Likes

Would be great to know if you read the webxr documentation:

And what was missing there to get started

Hello @Juan_Cruz_Ayoroa just checking in, was your question answered?

Is this still unanswered?
I’m having the same problem

Can you describe your problem in more detail? What is your experience you’re trying to run?

I tried running playground VR example with Oculus browser, Chrome and Firefox, but when I click on VR mode, the browser just shows a split view of the scene, instead of going into full VR mode.

it will be very helpful if you share a reproduction. Make sure no exception is thrown, make sure your scene is configured correctly and that you are using webxr correctly (as described in the docs). Do you get the same behavior when opening a playground from the docs, or is it just your scene that fails?

1 Like

I figured out my mistake, My VR hardware was not set as default so BabylonJS had no way of knowing on which VR device to run the project.

HI

What it means: “set to default”?

I believe I had some changes to make in the Oculus application itself, regarding the usage of the hardware I have in third party applications and other applications labelled as unknown in Oculus app.
That solved problem for me.