[Solved]ES6 version typings issue: engine.ts has no exported member 'IDisplayChangedEventArgs'

got typing error on ES6 version (4.1.alpha1)

node_modules/@babylonjs/core/Engines/engine.d.ts:8:10 - error TS2305: Module '"node_modules/@babylonjs/core/Engines/engine"' has no exported member 'IDisplayChangedEventArgs'.

8 import { IDisplayChangedEventArgs } from "../Engines/engine";

Checked code and looks like engine.ts is trying to import it from self import { IDisplayChangedEventArgs } from "../Engines/engine";

@sebavan its know issue ?

Thank You

Looks like a bug to me :slight_smile: I will fix it ASAP.

Are you relying on VR ???

If not where you having the issue before 4.1 ???

I am trying to narrow the issue as this does not look to have changed recently.


I was not using ES6 version before but I can check older versions.

Regarding VR I am not using it.

import { FreeCamera } from "@babylonjs/core/Cameras/freeCamera";
import { Engine } from "@babylonjs/core/Engines/engine";
import { ShadowGenerator } from "@babylonjs/core/Lights/Shadows/shadowGenerator";
import "@babylonjs/core/Lights/Shadows/shadowGeneratorSceneComponent";
import { SpotLight } from "@babylonjs/core/Lights/spotLight";
import "@babylonjs/core/Loading/Plugins/babylonFileLoader";
import { Material } from "@babylonjs/core/Materials/material";
import { StandardMaterial } from "@babylonjs/core/Materials/standardMaterial";
import { DynamicTexture } from "@babylonjs/core/Materials/Textures/dynamicTexture";
import { Texture } from "@babylonjs/core/Materials/Textures/texture";
import { Color3, Color4, Vector3 } from "@babylonjs/core/Maths/math";
import { Scalar } from "@babylonjs/core/Maths/math.scalar";
import { AbstractMesh } from "@babylonjs/core/Meshes/abstractMesh";
import { MeshBuilder } from "@babylonjs/core/Meshes/meshBuilder";
import { TransformNode } from "@babylonjs/core/Meshes/transformNode";
import { AssetsManager } from "@babylonjs/core/Misc/assetsManager";
import { Scene } from "@babylonjs/core/scene";
import { BackEase, EasingFunction } from "@babylonjs/core/Animations/easing";
import { Epsilon } from "@babylonjs/core/Maths/math";

have these imports

but as I said, looks like engine.d.ts file is trying to import stuff from it self.
import { IDisplayChangedEventArgs } from "../Engines/engine";

I tried smthg but it is weird i never had the issue before :slight_smile: l ll try to dig why.

This should fix it in the next npm release: https://github.com/BabylonJS/Babylon.js/pull/6372

Thank you will check after npm release :slight_smile: