Some glb model is not showed appropriately

Hi @julien-moreau,

I try to implement a simple BJS Editor tutorial how to make VR walkthrough demo of WebXR with using 3DCG city model (PLATEAU: See the link of the bottom).
But it is difficult to confirm actual position of the model imported on Babylon.js Editor.
These are three example of the same 3DCG model.

The 1st screenshot is on Blender 2.93.

The 2nd screenshot is on Babylon Sandbox

The 3rd screenshot is on Babylon.js Editor 4.0.0 rc-3

I could barely recognize the model. But some points are different from my expectation.

  • No model is showed but barely showed after releasing parent-child relationship between “root” and other child meshes.
  • Background is black.
  • I could not recognize position relationship between the model and Cube (standard mesh at default position)

I tried to change scale and position of the model on BJS Editor but nothing resolved.

My expectation is that I can control the position and scale freely then I can implement a walkthrough demo.

Basically the editor can successfully recognize and control imported 3DCG model. I think the PLATEAU model itself or my conversion from fbx to glb has cause the issue.

Here is the sample model I showed on the above screenshots. I’m sorry for bothering you everytime. If you have some awarenesses, it would be great helpful for me.

20210611_3DCG_examples.zip (3.0 MB)

Ref: Project PLATEAU
MLIT (Ministry of Land, Infrastructure, Transport and Tourism in Japan) published city model around Japan since March 2021.
PLATEAU [プラトー] (mlit.go.jp)

Adding @bghgary

@Deltakosh I think this is an editor question and @julien-moreau is already pinged :slight_smile:

1 Like

Sorry:)

1 Like

Hi @Limes2018 !

I’ll download and test it ASAP ! I’ll also compare imported data in the editor vs imported data in the sandbox using the Babylon.JS Inspector to verify that values and hierarchy are same.

I’ll let you know tomorrow

@julien-moreau

Thanks for quick reply with your busy work. I’d appreciate you!

Hi @Limes2018 !

I’m fixing the FBX loader of the Editor because I can see the geometries are badly imported for this model.
Can you also share the GLTF file you have created as well?

Thanks!

@Limes2018 what I can see in the FBX file is that the vertices positions have extremely high values (see screenshot below, up to (+ or -)4000 units). They are also not scaled (always (1, 1, 1)) and are all at position (0, 0, 0). Like all objects are at (0, 0, 0) and vertices have the transforms baked in it.

Sharing your GLTF file would help me a lot to understand how it has been converted. If it’s consistent, then the problem comes from the FBX source file :frowning:

Using ThreeJS Editor, I can see that the FBX file gnerates the same issue. Try to import your FBX here: three.js editor

Many thanks!!

I just wanted to inform you about my preparing gltf and original fbx files.
Thanks for your waiting a few minuets.

I uploaded two 3DCG file. These are the same building model.
(1) fbx format
I got the file from PLATEAU official site.

53393632_bldg_6677.fbx.zip (3.0 MB)

(2) gltf format
I converted it by Blender 2.93.
gltf_PLA_53393632_bldg_6677.zip (2.0 MB)

I checked (1) on three.js Editor and the result seems to be the same as you said.

Hope these would be helpful for you.

@Limes2018 just tested and I can confirm that I get the same result in Editor and Sandbox for values. The geometries contain too high values in their positions.

When you import the model in Blender, are they well placed? Are they placed well relatively to position (0, 0, 0) ?

@julien-moreau
Thanks for checking! I understood the model itself has geometry and position issues.

When you import the model in Blender, are they well placed? Are they placed well relatively to position (0, 0, 0) ?

Actually no. I could not recognize position relationship between the PLATEAU model and cube (standard mesh at default position). Regarding Blender, I can focus each PLATEAU mesh via “View” > “Frame Selected” options.

Sorry for taking your time. The model itself causes the issues. I’ll search for other solution from the modeling point of view.