Spatial scan obj file won't load into Babylon

I have an obj file that represents a spatial scan from a HoloLens device. This file loads correctly on other 3D viewers, but not on Babylon, the loading spinner never goes away and there is a JavaScript error in the console (in the playground link below, it just never loads anything). I have tried configuring the engine options for uintIndices and that did not make any difference. I also tried with a smaller spatial scan mesh (i.e. less vertices) and that did not work either.


As for the Playground, there is wrong link to your file. It should be

But I had no success to load your file into Sandbox, and this is really strange. Meanwhile it is OK at .

Thank you for the link correction – I went ahead and updated the sandbox code.

Yes, it opens just fine at but not in Babylon.js. Any help would be appreciated.

I don’t think your file is valid because the faces data point to normals/uvs that don’t exist in the file.

For eg, the last line in the file is:

f 85946/85946/85946 85945/85945/85945 85944/85944/85944

It should be:

f 85946 85945 85944


Same thing for all “f” lines.

After these corrections it does work:

1 Like

We changed the way we were exporting the file and it worked correctly this time. Thank you for your help!!