Transmissive and Opacity map issue

Opacity map giving model glitches and transmissive maps not giving see through effect. can some help, how to chive this output

Hi and welcome to our Community,
I’d love to help (if I can) but it’s kind of hard for me to figure it out from just these screenshots. I’m not even sure what I should be looking at :face_with_hand_over_mouth:

Any chance you would be able to set-up a ‘Playground’ for us to review?

This is your best chance at getting accurate input from us.
And then, doesn’t matter if it’s buggy of course. We would just need a base to look at. You can also make it a ‘dummy’. No need to use the ‘real’ sources if for whatever reason you cannot share’em.

Sidenote: I’m using BJS materials a lot. In fact, I create all my materials for babylon straight in BJS (with a few exceptions). I haven’t noticed anything wrong with’em as of today (although this can always happen, of course :sweat_smile:)
Reason why we would really appreciate to have the PG (playground).

Again, welcome to the Forum. Don’t hesitate to ask if you have issues setting-up your PG and… meanwhile, have a great day :sunglasses:

1 Like

Maybe OIT can help you. Mind when using it you that are trading off performance for a more correct rendering.

1 Like

I appreciate your response, @mawa.
For that reason, I’m using Substance Painter and Maya to create this translucent bag for GLTF. Using the painter’s transmissive map prevents me from seeing through the other side sections, such as the transparent belt.
I tried using the Opacity map, which shows every side of the model, but it had some undesirable quirks that were obvious in the GLTF version of the model. I just need to know the parameters or procedure to resolve this painter pipeline and Maya issue.

Thanks for your reply,
I’m still not sure how(if) I can help here. Again, the PG would be best (if by any means possible?)
I don’t use maya, but there are a number of conditions to properly export pbr mats in gltf. Did you read this part of the doc?

Without a PG again, I can only make assumptions. For whatever the source though, mats still need to conform to the BJS pipeline/channels (else, are discarded). So, this looks to me like an alpha/depth rendering issue. You could start trying to add the property of ‘needDepthPrePass’, see what it does. If you have a single mesh and just one material wrapping everything, you could try split the bag and belt in two meshes. This would give you more latitude to work on each material and force depth write the mesh manually using the ‘alphaIndex’.

Don’t know if anyone here can spot your issue without a PG (or at least screenshots from your materials and export settings). Still, hope this can help orientate your search. Meanwhile, have a great day :sunglasses: