Web XR experience not working in babylon 4.1


I’ve tried to enable XR experience in my babylon project which has been built with VueJS.
I was used the XR experience code as following.

const xr = await scene.createDefaultXRExperienceAsync({});

After I’ve added this code, I could see the VR turn on icon at the bottom right corner of screen.
But it never worked for me. I couldn’t get the divided VR screen by clicking this icon.

I’ve checked console window and I’ve got a following warning message.

babylon.js:16 BJS - [07:34:32]: glTF / glb loaded was not registered, using generic controller instead
babylon.js:16 BJS - [07:34:32]: Falling back to generic models

I’ve attached screenshot of tracks for those errors. please check the screenshots.

Help me to solve this out please. Any suggestion or help would be much appreciated!

1 Like

Pinging @RaananW

Thanks, @Deltakosh ! @RaananW can help me to solve this problem?


Those are not errors, but warnings that notifies you that in order to use the controllers lib you will need to import the babylon loaders package (for the GLTF loaders).

The package you are missing is this:

I just noticed there is a typo in the warning (should be loader and not loaded), might be a confusing message. Will fix that

1 Like

Thanks for your clarification, Raanan

I am wondering what is main problem that the XR is not working now.

I’ll try to make simple code base which is mini-prototype of our project and then will share with you.


Those warnings should have no effect on your XR scene. Will be great to see what’s wrong with it. maybe an exception thrown?