Webpack compilier error after V5.21.0

"webpack": "^4.46.0"
An error occurred while Webpack compiling code with v5.22.0 || v5.22.1.
No problem before v5.22.0, i had test v5.21.0, v5.17.0

Hey @DWork,
It’s the same problem as here

Webpack v4 does not understand some new JS features. It would be great if you could upgrade Webpack to v5.


That would be the recommended solution, yes. Otherwise you can also use Babel to convert the input to an older version of JavaScript.
Migrating to webpack 5 should be straightforward though. Version 4 is 2+ years old and is not actively maintained.


Create React App still uses Webpack 4, which may cause some people to be stuck on 5.21.0

EDIT: Actually I’m wrong my issues are unrelated.

Do you mean the official facebook create react app?

GitHub - facebook/create-react-app: Set up a modern web app by running one command.?

Was just coming back here to say I was wrong (it’s on 5.70.0), though am getting errors with 5.22.0 also.

Uncaught (in promise) TypeError: _babylonjs_core__WEBPACK_IMPORTED_MODULE_1__.Color3.FromHexString is not a constructor

My bad :sweat_smile:

It installs this:


That’s because you used “new” where new should not have been used. If it is in our code we should fix that asap

1 Like

That was in my code, interesting that it was working up until this update. I guess something got more strict. Thank you.

yep, because up until the update we used es5 syntax in these packages

Yes, the mainstream is still Webpack4. Webpack5 compilier changed a lot. Some old js plugins couldn’t being compilied