3dsmax to babylon,have a cube background

tutorial

#1

in babylonjs have a cube background ,but 3dsmax have not.
I don’t want this cube background,how to do it?


#2

Hello!
Well we may need more info to help. Can you share your code? or the 3dsmax scene?


#3

Do you use createDefaultEnvironment function? Looks like some wrong settings on it.
Few minutes ago I exported some objects from 3dsMax and it worked well.
More infos will help :slight_smile:


#4

https://www.babylonjs-playground.com/#DMLMIP#1
my code from this demo but use my 3dsmax.babylon file.
I think it is not code’s error,but new user can’t upload file,
how can i upload my 3dsmax scene?


#5

new user can’t upload file


#6

my 3dsmax scene


#7

can you post the 3dmax.babylon file on a host fileshare somewhere?


#8

https://drive.google.com/open?id=1zlifTqsaRBCTCk2f4Cxgvr9xUb-5iw3n
I upload my 3dsmax into google driver


#9

I’ll check it out after dinner here.


#10

https://www.babylonjs-playground.com/#DMLMIP#1
have no cube ,when i use my 3dsmax.babylon ,sence will have cube.
//var helper = scene.createDefaultEnvironment({
// enableGroundShadow: true
//});
//helper.setMainColor(BABYLON.Color3.Gray());
//helper.ground.position.y += 0.01;
i delete this code,cube will disable,why?


#11

is it a cube then or the ground plane?
I do not have access to 3dmax, I would need the .babylon file that you are referring to.

What happens when you initiate the scene with the bare bones:
var createScene = function() {
var scene = new BABYLON.Scene(engine);
var camera = new BABYLON.ArcRotateCamera(“Camera”, -Math.PI / 2, Math.PI / 2, 12, BABYLON.Vector3.Zero(), scene);
camera.attachControl(canvas, true);

    ...You Import mesh stuff ...
return scene;

};


#12

Hello please create a repro in the playground
(Using External Assets - Babylon.js Documentation)


#13

https://drive.google.com/open?id=1MdDTJf3uRSDuDz7yNZcLONLP_o1-fdJs this zip have babylon file


#14

@1113 then this is the issue, and not the exporter
createDefaultEnvironment is creating a box used as skybox of scene, and a ground.
You have few options

1.this will completly remove the box

var helper = scene.createDefaultEnvironment({
enableGroundShadow: true,
createSkybox: false
});

  1. this will make the box bigger, so it’ll look maybe like a real skybox

    var helper = scene.createDefaultEnvironment({
    enableGroundShadow: true,
    skyboxSize: 1000
    });
    
  2. fix your camera radius, or if you have multiple cameras, make sure you are using the right camera as activeCamera.

If still doesn’t work then we definetly need a playground with your code :slight_smile: