Looking at the commits I think there is some confusion here. In the code keysLeft, keysRight, keysUp and keysDown were probably originally named after the specific keys on the keyboard, ie the left, right, up and down arrows, not the direction the camera moves. So we do have keysUp are those moving the camera forward, in the z direction, keysDown are those moving the camera backwards, in the -z direction. What I think @PetterG wants to add are an arrays of keys that move the camera in the y and -y direction. So perhaps a better system might have been keysForward, (z) keysBackward, (-z) keysLeft, (-x) keysRight, (x) keyUp (y) and keysDown (-y) however for backward compatibility this renaming is not possible.
Any more thoughts on this?