Animation Group, Morph Targets don't Export, GTLF

Hey, I have run into a small problem where I cant seem to export my character with morph targets when I use animation groups! It exports fine with All Animation when there are no anim groups but as soon as I add them the morph targets don’t show in the export. I have a character with various animation loops (Idle, jump, walk, etc) I also have some basic facial anim using morphs. I have tried a bunch of different things redoing morphs, animations, settings, etc but with no luck. I have even set up a basic scene with a sphere and two morphs but still can’t get it to export morphs with anim groups. I’m using 3ds max 2018, the latest Babylon Exporter 20201020.3 exporting as GTLF. This is possible, right? am I missing a crucial step or setting somewhere? Any help or suggestions would be awesome.

Here are my settings and my basic scene test


Here are the exporter settings.

pinging @Guillaume_Pelletier

Hi All, this is certainly related to an identified bug with Morph target export ( #855). I did not had the time to dig in but this is the next one on my list. In the mean time @ShadowSpace if you can provide us the basic scene with sphere and morph target to repro, it certainly help us to move faster on the topic.

1 Like

Thanks for the quick reply @Guillaume_Pelletier

Here’s a link to download the 3ds test scene and the exports GTLFs both with and without the anim groups. Let me know if you need any more info to help.

In the meantime, is there an older version of the exporter that I can use that before the bug?


Hey @Guillaume_Pelletier just wondering if there has been any progress with the bug? Is there an older version of the exporter that I can use to get my project completed. Thanks in advance.

hey, I’ve been busy on other topic, i will have a look today. could you update the wetransfer file then i can have a look on it.

Thanks @Guillaume_Pelletier here’s a new link to the test file.


I opened an issue and nearly solve this case… I’ll keep you posted.

This is corrected. PR done.

Hey @Guillaume_Pelletier
Sorry to be a pain but I have installed the latest version, however, the morph targets are still not exporting with anim groups.

The morph target manager doesn’t appear in the log under Exporting animation like it does when there are no anim groups. Is this correct?

With anim groups

Without anim groups


Ok i done some test, the build version is correct and i transform the basic scene with sucess (attached). In all case you might have check the box “(Animation Group) export non-animated object”. (The reason behind is morpher is designed as Modifier into Max) (81.5 KB)