Morph Animation


#1

Hello Guys
i want a animation to export with Morph animation
but its not showing anything when i export
can you guys kindly Help
here you can download the file
https://drive.google.com/file/d/1jc5uMZDIsH1BA3ZmYYeSarsg0v-edhUI/view?usp=sharing


#2

On mobile, short answer. bjs don’t support morph animation in .Babylon format. Do not know about others. Only the targets. Do the animations after load.


#3

Bjs does support morph targets in both gltf and .babylon file format :slight_smile:
https://doc.babylonjs.com/resources/3dsmax#exported-features

pinging @PatrickRyan or @kcoley to see if they can spot the issue with your 3dsmax file


#4

@Simon_Jamil, it looks like you set up your scene correctly except for one small detail. The morph target you assigned is no longer in the scene. Your base mesh shows the animation still in Max because I assume that Max stores the morph information in the Max file. However, the glTF and Babylon files will store the morph mesh triangle list and interpolate between the two vertex lists since that is much less data to store (two triangle lists and one integer curve) than the position of each vertex per frame for your animation.

So I recreated the steps for making a morph animation for you to make sure you can step through it and get your desired results.

  • First create your two meshes (default and a copy which you deform so that your triangle list stays the same.

  • Second, select the base mesh, right click and choose Babylon… > Babylon Animation groups. Then Click on your animation (rename if you like) and then click Add Viewport Selection.

  • Third, open the Babylon Export window and make sure you only have the base mesh selected with none of the morph targets. Check the “Export only selected” checkbox and export your file. Note in the output window that under exporting animations, it should tell you that there was morph data exported.

  • You can see in the sandbox, that the mesh does morph, and has animation data from the play bar at the bottom of the screen.

Let us know if you still run into any problems after leaving your target mesh in the file when exporting.