AnimationGroup not wokring as intended

Hey folks,

so I got a gltf-file. This file contains an animated fox. When loading the file into the babylonjs sandbox/inspector and starting the animation group via click on the “play” button, the fox ist animated as intended (walking around, staring at the camera, jumping away). But when coding, loading the file into my scene and starting the animation at any given point will result in the following: the fox will only slide. His seperate body parts are not moving as they were when inspecting the file in the sandbox. It seems like only the “most upper” animation (changing his overall position of the fox mesh) is being played. Thats why the fox is sliding instead of seeing the correct walking cycle. I tried everything but nothing will change the behavior.

Using babylonjs 5.13.1

Thanks a lot for your help.


I have to ask first: have you tried upgrading Babylon’s version? Just to check against all the latest bugfixes


Found the solution. I forgot to add the bones to the node material. That’s why it was working correctly with the standard material in sandbox/inspector but didn’t after assigning the node material to the mesh within the code.
Solution here: