Blender exporter shadows not working properly

I have thought of removing checkOnlyOnce. It never really worked. The default is off. A checkbox in material custom properties turns it on.

The shadow min & maxz are not exported. I did not even know they existed.

I don’t know if that exists in Blender and if yes if people use it…

For shadows I do not use anything Blender Provides. BJS has 4 type of shadow maps, Standard, Poisson, ESM, & Blur ESM. Blender has no concept of this. There are then a number of additional custom properties enabled based on the type. Min Max Z, if added, would have to be done as custom exporter properties as well.

The only improvement that I have on my radar right now is getting the photo-realistic skin option in Make-Human Blender addon to export.

1 Like