High Quality Shadows

If i set the Shadow settings in Babylon Sandbox to high and use a Filter site of 0.00001 in PCF mode.
I still dont get that crisp shadows. We would need more. Even if its crawling down to 1FPS.
We use those settings so render out UI elements in 4k resolution.

Please make an Option for ultra high Quality Shadows. Performance doesnt matter.
Maybe Raytraced Shadows are an option?

Can you repro your current setup in the playground?

No, cause its for direct use by Artists.
Just click on “export and run” from Maya.

And what is the size of your shadow maps?

I havnt found a way to change the shadowmap in the sandbox.
How do i do that?

pinging @drigax for that question :wink:

Hi oglu,

You can set the shadowmap via:

@Drigax I guess @oglu is speaking about the shadowGenerator Render Target size, not the lightmap ones :wink:

I have no idea in that case, sorry.

@Deltakosh should we add the shadowmap size in the generator property panel ? Or is it a bit too edge case ?

I was sure the size was read from 3dsmax already. If it not the case we should do it (for Maya as well)

Ohhhhhh on the exporter ! Gotcha. @Drigax could you tak a look on the light export if it is not already in the babylo light properties ?

Ah, sure. I can take a look at our light export info :slight_smile:

The maya exporter does not export shadowmaps. How would i set there the shadowmap size?

If i would search for it i would take a look at the shadow settings in the Sandbox. I would expect its a setting there.

I was mentioning the 3dsmax exporter actually :slight_smile:

I could add a button in the render target texture property grid to rescale the shadow map

That would be great.
Thanks

You can track the progress here: Change shadow map size from inspector. · Issue #6887 · BabylonJS/Babylon.js · GitHub

1 Like