Can't switch to TS in the playground

Hello, I want to see the examples TS code and I can’t switch to TS. When I click TS the code window is resetting and is showing no code.

Os: macOS 10.15.6
Browser: Brave, tested also in Safari with the same behaviour
Here is a short video: Imgur: The magic of the Internet

1 Like

Welcome aboard!

Have you tried with Chrome/Firefox? I know there can be some problems with Safari…

Thank you.

Yes I tried Firefox, when I switch to TS in the playground on any example I get empty code as in the video.

Ok, I didn’t realize you were speaking about the examples coming with the playground.

I do get the same behaviour here, so it must be a bug.

Summoning @Deltakosh or @RaananW.

1 Like

Good catch! Seems to be an issue with the language switcher flow. Looking into that.

Just a side note - when clicking typescript the example code itself will not switch to typescript (thou i suddenly think it is not such a bad idea :slight_smile: ). It will initialize the playground in typescript mode.

Oh, I am sorry, I thought you are providing examples for TypeScript, maybe in the future :slightly_smiling_face: .
Thanks for the reply.

No need to apologize, it is actually a great suggestion. The playground doesn’t support that currently, and there is no way to do it automatically (without adding typescript overhead), so I will keep that as a suggestion/improvement.

Anyhow, pressing the typescript button should have at least not fail :slight_smile:

1 Like