Clipping issue with skinned meshes

My skinned meshes disappear when my camera moves too close. I followed the tip in this thread which resolves the issue:

mesh.alwaysSelectAsActiveMesh = true

Is this the recommended way of doing it? I’m a bit concerned that it will affect performance and wonder if there are better ways?

It is the recommended way, but another (more involved) option is to set an initial bounding box a little bigger / bigger enough to encompass all frames of the animation. That way you don’t need to set alwaysSelectAsActiveMesh = true and you will get better performances as the mesh will still be culled.

1 Like