Flickering on moving


i want show the Model Wireframe with mesh.enableEdgesRendering. But i have the problem that if we move the Camera same lines disappears on moving. How i can fix that? That die Edges Line always present?

Here a demo example: https://playground.babylonjs.com/#E7R8F8#8

I believe it’s because of your value for the edge rendering max angle. See SS below.

The value you have defined is below 1, where I believe to ensure that all angles are detected it should be above. I guess a value of 2 on this model works (although it can be fine-tuned if needed).

But this means i have to adjust this value for different models manually?

Is here an another option do show wireframe without transparency?
With scene.forceWireframe = true i have transparency …

normally not, except if the model is very high definition. You can still find a one fits all value I believe.

I can’t find a number without flickering.
Is here a another method how i can show all wireframes without transparency?
Like in edit mode in Blender?

To be honest, I don’t really see it flickering. May be by flickering, you mean the moirage effect or the way the material reflects the light.

You can lower this by setting an alpha on the material lines, even more if creating a more complex material. Or you could create a node material. Personally, I don’t see anything else (but my knowledge is still limited). Hopefully somebody else will kick-in.… Meanwhile, have a great day :sunglasses:

I did see the flickering, this was being caused by the edge lines z-fighting with the material. By tweaking the material’s zOffset property, I could eliminate the flicker: Flickering on moving | Babylon.js Playground (babylonjs.com)


Thank you @carolhmj,

wireFrameMaterial.zOffset = 10, was the magic :slight_smile: