GPUParticleSystem.IsSupported true, but nothings shows up on Chrome

I’m trying this example on Chrome Android 122 (Pixel 8 Pro) and I get the GPU checker rendered, but when I check it I cannot see any particles on screen.

If I uncheck then I start seeing the particles (using CPU). GPUParticleSystem.IsSupported returns true.

I can not repro on my devices :frowning:

@bghgary and @Cedric any of you having a device close to this one ?

Works fine for me on OnePlus 8.

1 Like

Also fine on my Oppo x5 lite / Android 13

Could you try unchecking GPU particles and checking again?
It usually works in first render, but then after reloading or, unchecking and checking, it doesn’t.

Indeed! It works, uncheck/check then particles are not visible. Webgpu works fine.
Any idea why it happens @Evgeni_Popov ? Nothing in the logs.

Still works for me.

I tested on my Samsung device and it does work for me, even after unchecking /checking the “GPU” checkbox (it takes a few seconds to restart the particle system when you recheck the “GPU” setting).

As an OS update was pending, I performed it, but it continued to work after the update.

same for me !!! we really to find one of those devices to repro :frowning: