Playground for WebGPU not working

The Playground (for example: works fine for WebGL2. However, when switching to WebGPU, both Chrome (120.0.6099.225) and Chrome Canary (122.0.6253.0) give same error: “Cannot read properties of undefined (reading ‘trackUbosInFrame’)”. Meanwhile Microsoft Edge (120.0.2210.133) renders the house, but with a black roof.

How to resolve this issue?

Pinging @Evgeni_Popov

Just wanted to add that I see it rendered on chrome:

Which Chrome version? My Chrome still doesn’t render.


We use different version.

I do see the same thing than @RaananW on my side (Chrome 120.0.6099.218 (Official Build) (64-bit)).

@jackny Are you sure WebGPU is in the list of supported engines in the Playground?

It already happened to me that after an update, my Chrome did not support WebGPU anymore (until the next update)…

Regarding the black roof, it’s because there’s an error when reading roof.jpg. You can display the error by adding an observer to BABYLON.Texture.OnTextureLoadErrorObservable:

It seems the roof.jpg file is invalid in some way (maybe the header?): just opening and resaving it in makes it work…

1 Like

Yes, WebGPU is in the list.
But it doesn’t render anything in my Chrome (120.0.6099.225).

I just upgraded chrome to be sure we are testing with the same version -

It renders the same. As @Evgeni_Popov , it might be a temp issue after an update. Make sure you don’t have any download errors, try clearing cache for good measure, and see if you can maybe try and restart chrome.

Is the error the same on both canary and stable?

Same black roof in Vivaldi browser in Webgpu.

Works normally with other textures:

1 Like