Help with the NavigationMesh properties

Hello everyone,
I just started using the navigation mesh plugin and I am experiencing a lot of difficulties setting the right properties of the navigationPlugin. Here is a PG link:
I basically have this huge ground and when i run the code i just get “Could not build Detour navmesh.” :frowning:

I’m taking a look.

the cell size value (cs) was too big and resulted in a voxelization with less than a cell.
With a more appropriate value, it works:


Thank you very much, it worked.
However, now I am facing another issue. Most of my meshes aren’t recognised by the navigationMesh:

I tried playing with the parameters but it doesn’t seem to work. Here is a link to my scene:
I also realise that I have a lot of trees so I decided not to include them in the navigationMesh because I fear it is going to slow down the performance of my scene.

Ok I fixed it, i just decided to create an instance of a box around each of my buildings, then i added all the boxInstances in the setup array of my navMesh and it worked.

1 Like


1 Like