Importing a mesh removes the skeletons and animations

My character looks like this -
image It’s rigged and animated, but when I load it into the playground, it looks like this -
, and the skeleton doesn’t get loaded. Any idea what the problem is?
Playground -

I only started with Babylonjs myself VERY recently, so I might be entirely wrong. Your question reminded me of this video-tutorial:

One of the main points being, the mesh itself does not know anything about being animated. So you would need to access and add the AnimationGroup (which your character file has, as can be found in the Sandbox) to the mesh.

That is my guess so far - I hope someone else chimes in, in case that was not as helpful as it was intended :slight_smile:

1 Like

@saathvik, uploading the (Blender?) file could help us debug this. For example, in Blender, if you hide the armature using the H key and try exporting to .babylon, the skeleton will not be exported

I exported the .blend file to .glb, and everything worked fine in the sandbox, but not in the playground. I exported it to .babylon. Even that didn’t work in the playground. I thought there was some problem in exporting the file, and opened the .babylon file in the sandbox - again it worked fine

What I’m trying to say is that there was nothing wrong with the file, because it worked in the sandbox. The skeleton was loaded, and the meshes were positioned correctly

@saathvik, could you share the glb, it is kind of easier to work with as it is only 1 file :slight_smile:

Here what you see is the T pose without any animations, I wonder if it only works when animations are applied in the sandbox ?

Huh. I think there was something wrong with the file, because it’s working now, wit the .glb file -

1 Like