Issue with babylonjs 5.57.0 with typescript 4.3.5 + angular 12

I am using angular version 12 and typescript version as 4.3.5. I am not able to run the babylonjs 5.57.0 version. I cannot change my typescript version and angular version due to other dependencies.
Can you please suggest which version of babylonjs i can use?
or
can u please provide an option to use angular 12 with babylonjs5.57.0 without changing typescript version?

cc @RaananW

can you explain what the actual problem is? is it a typescript issue? or is it a build issue?

Even i am getting the some errors while doing npm start with the same versions of babylonjs 5.57.0 with angular 12 & typescript 4.3.5.
It is asking to upgrade the typescript to >4.8.2 to <5.0.0. After updating it is working.

But the above problem represents that he cannot update the typescript because of his other dependencies in the project.

Is there any solution to fix this?

Even i also tried in my local with same versions.

Based on that, the actual problem is using the old version of typescript with 5.57.0 version of babylonjs. Any fix for this?

why can’t we use the old typescript version in babylonjs 5.57.0 or in latest versions?

You can ask typescript to skip lib check, and add missing typings (if any). But still, as I previously asked, it would be great to know what the actual error is. Otherwise it is very hard to help with a fix.

An example project that fails will be helpful as well