Issue with last version

Hi everybody,

Yesterday evening, my code worked correctly but this morning, i get this error and the canvas is not working anymore.

image

Can anybody help me ?

Thanks in advance,

Boris

4 Likes

image

All global illumination examples also fail to run.

1 Like

I got the same error in the playground…

Hello,
I was about to publish a bug report as well and I just saw this post.

Yes, the CDN seems to be broken. Even the Playground is down.

@RaananW I just tried to pull upstream and build, the issue seems to come from your last commit
“Allow shader precompile by dividing effect and thinEngine” resulted from the merge of this PR

The previous commit “Fix wrong type casting” from @Evgeni_Popov works fine.

++
Tricotou

I`ve got the same error. I cant visualize the model in the canvas. It will be solved or we need to do some changes?

If you’re working with a local project, you can revert to a previous version; they should have fixed this issue.

Hi @all, I’m also getting cdn related issues

webGLPipelineContext.ts:515 Uncaught TypeError: Cannot read properties of undefined (reading 'scale')
    at e.setVector2 (webGLPipelineContext.ts:515:45)
    at e.setVector2 (effect.ts:1342:32)
    at e.apply (postProcess.ts:1014:34)
    at e.directRender (postProcessManager.ts:132:31)
    at rgbdTextureTools.ts:88:56
    at e.executeWhenCompiled (effect.ts:548:13)
    at e.s [as callback] (rgbdTextureTools.ts:82:41)
    at e.notifyObservers (observable.ts:393:49)
    at e.L [as callback] (texture.ts:484:39)
    at e.notifyObservers (observable.ts:393:49)

Only those who do nothing don’t make mistakes… :wink:

I’m sure it will work fine ASAP. Let’s trust the team !

3 Likes

Uncaught TypeError: Cannot read properties of undefined (reading ‘0’)
at e.getAttributeLocation (effect.ts:456:21)
at t._bindVertexBuffersAttributes (thinEngine.ts:1434:34)
at t.recordVertexArrayObject (thinEngine.ts:1499:14)
at e._bind (geometry.ts:426:39)
at t._bind (mesh.ts:1787:28)
at t.render (mesh.ts:2419:18)
at e.render (subMesh.ts:427:29)
at e._RenderSorted (renderingGroup.ts:274:21)
at e._renderOpaqueSorted (renderingGroup.ts:204:24)
at e.render (renderingGroup.ts:143:18)

Sure ! Unfortunately I think most of the Team is located in West USA where it’s 2:23 AM :smiley:
I would be glad to help by reverting the CDN on the previous commit but I have no hand on this ^^

For those of you who are stucked to work today, I just built the last working version of the BabylonJS Core and pushed HERE. That’s a good way to remember that nobody should rely on the CDN for production :innocent: (Told by the guy who had his website broken 5 minutes ago :joy: )

++
Tricotou

3 Likes

Thanks!

I thought I had broke my code, starting to feel incredible insane :slight_smile:

I’m having the same issue, seems to be in effect.ts. Sure it will be fixed soon.

image

Same Error here… :dizzy_face:
스크린샷 2024-04-23 20.50.44

Error occurs in

  • Desktop - Chrome, Safari, Edge
  • iOS - Chrome, Safari

Error doesn’t occurs in

  • Android Chrome, samsung browser
  • Desktop Firefox

Is it something related to browser web engine like webkit?

Thank you!! it works. :smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear: :heart::heart::heart::heart::heart::heart:

nice!!
i should tattoo this sentence on my right arm

cc @RaananW
We have the fix in and a patch is coming :slight_smile:

1 Like

fixed already, should be fine

4 Likes

Yes it is… Thanks to be so quick !!!