Level of Detail on Dynamic Texture

Not sure if this is a bug or something I need to set/change in the properties. In the image, the top mesh’s material uses a dynamic texture and the bottom is a regular texture. They are constructed from the same image. How do I get the dynamic texture to use the same LOD, or whatever, like the bottom normal texture?


Hello there,
I’ve been with LODs for a while. If you have a playground example, I think I can help.

1 Like


Fixed, the url. Don’t know how I got those backwards…

The 3rd parameter of the dynamic textures allows you to turn on mipmaps on dynamic textures. It is off by default for perf reason, whereas it is true by default on Texture (as it only ever needs to be done once vs dynamic which needs to be computed for every update)


Thank you for that!