Load glTF/glb in Playground broken for BabylonJS v4.1.0, v4.0.3, v3.3

Hi, there seem to be some issues with Babylon Playground ATM.

All examples work fine in Playground 4.2.0-rc.3 however in any other Babylon version they crash with the error: Unable to import meshes from ...: importMesh of unknown

It also seems to affect SceneLoader.ImportMesh and AssetContainer.


However, any of these (that loads gltf/glb) are broken in 4.1 and below:

Best Regards

All work for me:

I’m still having issues.

I have attached a screen recording, with the console open. I toggle all available versions of the playground https://www.babylonjs-playground.com/#8IMNBM#1

I noticed that I also got a warning for all versions that are broken:
babylon.js:16 BJS - [21:42:02]: Unable to find a plugin to load .gltf files. Trying to use .babylon default plugin. To load from a specific filetype (eg. gltf) see: http://doc.babylonjs.com/how_to/load_from_any_file_type

I have tested both Chrome and MS Edge and it’s the same issue in both.

Will try on another machine.

Try playground.babylonjs.com instead of www.babylonjs-playground.com: for me the former work (with your PG) but not the latter…

Still the same issues with playground.babylonjs.com

Thanks for the quick replies btw.

Tried on another machine and used phone as hotspot (i.e another network) and still have the same issue.

Checked the network tab in chrome devtools and status on all requests are 200.

Could it be related to location? I’m in northern europe.

We may have found an issue related to this one actually (It is because of the Unity Exporter plugin)
Can you try in a couple of hours (or tomorrow morning as I guess you are sleeping now ;))

1 Like

Thanks for looking into this!

Unfortunately, still have the same issues this morning.
Tested both https://playground.babylonjs.com/ and http://www.babylonjs-playground.com/ (and tested with disabled cache in browser.)

Still get this warning (and an error afterwards):
Unable to find a plugin to load .gltf files. Trying to use .babylon default plugin. To load from a specific filetype (eg. gltf)

I also have the same error for both links, both in Chrome and Firefox.

Looking at the network tab, I can see all packages are downloaded two times when selecting “4.1”, from the preview and the 4.1 CDN.

The preview files are downloaded from the index.html page and the 4.1 files from the index.js script (loadScriptAsync).

yes this is expected and that happens for me as well but still I do not repro the issue

wait! I may know why

Trying a fix
please give it a try in a couple of hours


Nice! It works now. Great job!

Edit: Thanks for taking your time with this. Fixing a bug without being able to reproduce it is an art :+1:

1 Like

Working here too!

1 Like

Yes this is not my passion though :smiley: