Maya mesh not animating in Babylon

The skelethon is animated, the mesh not.
I’m using Maya 2022, and babylon version v202111123

Could you share your source model so that @Guillaume_Pelletier can have a look ?


Saci2022 (781.7 KB)

The model stay on the position of the current frame when I export… that is it…

Pinging @Guillaume_Pelletier :smiley:

1 Like

The skeleton is not binded to any mesh but the cap, into maya.

When i move over the animation (frame 9 here) i obtain exactly the same with the exported GLTF.
So the maya file (the one i downloaded) has to be corrected to apply influence from bones to mesh ( i maybe have a corrupted file). Another point is that the file missing some texture ressources.

1 Like

What version of Maya did you used to open the file? I’m thinking the Maya 2022 is with a lot of bugs…
I tried to upload the textures but the file became heavy so I could not upload here

I unbided skin and binded skin again and started to work. I lost a long work on rig, but it worked.
Thank you for your attention on it.

1 Like

But I’m still confused… if there was no bone influence on the mesh, how did he do this pose on the babylon?

I mean this pose

I use 2020, to avoid bugs…

1 Like

This strengthens my theory that this Maya 2022 is the problem.

The support of Maya2022 is quite new on our side, and it was a lot of change into the Autodesk SDK, so it may drive to strange behavior. I will have a look with 2022 .

1 Like

Thank you :slightly_smiling_face:

could you send me back the correct file with a functional skeleton ?

Saci2022 (748.6 KB)
Here, but there’s no animation, I made a quick one yesterday just to test it, and I was doing the Weight Paint yet

It happened again with a model of mine, when I pressed delete by type non deformer history. For a strange reason delete the proper rig for babylon and rig in maya still works…