NME Code worked yesterday, not today

I’m using the cdn preview version of babylonjs, and this code I’ve saved from the nme doesn’t load

(Note the version is user-based. I’m on 4.2.0-beta.1)

Uncaught (in promise) TypeError: e.toFixed is not a function
    _emitFloat babylon.js:16
    _buildBlock babylon.js:16
    build babylon.js:16
    _processBuild babylon.js:16
    build babylon.js:16
    build babylon.js:16
    colorNME colorNME.js:72
    setup Sculptures.js:43
    setup Museum.js:39
    init index.js:160
    js index.js:176

Your PG does work for me (the PG is running 4.2.0-beta.1).

I have applied the material to the sphere:
And there’s no error in the console log.

1 Like

Idk how that’s happening. It is the same error in Firefox/Edge/Chrome, private windows without extensions.

Tried a different device, same issue.

Are you sure your https://preview.babylonjs.com/babylon.js isn’t cached?

it could be cached by your browser. I guess you already tried to clean your browser cache right?

Indeed, after CTRL+F5 I do have the error now!

Pinging @msDestiny14 as the problem appears to be in GradientBlock.

On my local repo:

Looking into this.

So the problem has to do with the recent update which has changed the declaration which requires the reference of the parent.


I now realize this is not clear and will look into changing this. Will keep you posted :slight_smile:

Hi again! I removed the requirement for the parent so your original should work now. :slight_smile:

1 Like

Yay thank you so much!