No matching version found for babylonjs@5.0.0-alpha.57

Hi,

When trying to update to the latest alpha using npm update, I get the following error:

npm ERR! code ETARGET
npm ERR! notarget No matching version found for babylonjs@5.0.0-alpha.57.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn’t exist.
npm ERR! notarget
npm ERR! notarget It was specified as a dependency of ‘babylonjs-gui’
npm ERR! notarget

Is this a problem on my end or has something not been published to the npm repository?

Yes.The latest version is 56

1 Like

The latest NPM always trailing 1 behind master is 56 whereas the playground and master are in 57 which is currently in Dev

I think the odd thing here is that npm resolves it to 57 and not to 56. There might have been an issue with publishing 57, as it is tagged and released. @babylonjs/core is at .57, but for some odd reason the umd package (core only!) resolves to 56.

should have written it before - there might have been an error with publishing babylonjs@5.0.0-alpha.57. we will publish .58 soon to unify all packages.

3 Likes

Thanks all for clarifying.