Nothing shows up in Windows Mixed Reality headset

Hi there,

I’m using Windows Mixed Reality headset. The first week when I tried the WebXR demos in the playground, everything worked fine. But late last week, I found the headset didn’t show anything when I ran the playground demo, even the simplest one. I’m using Chrome browser all the way. Any idea what’s going on?

By the way, is it normal that Firefox cannot load the scene? At least on my end, it’s always loading assets.

I’ve tried:
Reinstall Chrome browser;
Update the graphics card driver;
Test the headset in SteamVR and Mozilla hubs, everything works normal;

Thanks in advance.


I haven’t tested my MR headset for quite some time, but it always worked flawlessly. What chrome version are you using?

Firefox doesn’t support WebXR just yet, so yes - it is expected for it not to work. You can use the XR polyfill to get the scene to fallback to WebVR if XR is not available.

Hi Raanan,

Thanks for your reply! The Chrome version I’m using is 83.0.4103.61, which should be the lastest version so far. And yeah I also felt it stable when I tested on my WMR for the first few weeks, yet it’s been not working since last Friday. That’s why I feel weird. It seems that WMR is always loading the scene.

In addition, it worked once this morning, yet couldn’t render the controller models. If I remember correctly, the controller models should show up automatically when the scene is converted to VR mode using the VR Experience Helper. Not sure if that’s caused by low battery. And everthing broke again after I woke up the headset from the Mixed Reality Portal.

And also thanks for your explanation for the Firefox thing.

@RaananW, I’m seeing this right now in Firefox; WebXR is enabled but when I run I just get a blank screen on my simple demo (GitHub - 3dui-class-f20/babylon-webxr-sample: a simple babylon sample for webxr).

Edge Dev seems to work well, tho.

Hi @blairmacintyre - will check and let you know!

Hi Blair,

have you tried the latest preview? Working for me with streamVR and MR.

BTW - the project doesn’t have https enabled, but i remember you used some kind of a proxy instead, right?

sorry I never checked back … I just stuck with Edge Dev. The WebXR folks pointed me at various issues and we got it working.

1 Like