Possible upcoming iOS 15.4 bug

Well, 15.4 is out and they did not fix it. Tried my best up let them know that the last 15.4 beta before release still had the bug too -sigh-

cc @Cedric could you try in 15.4 ? I am still not on it at the moment :frowning:

I’m still on 15.3.1 and no update available so far (iPhone 11).
I’ll let you know when I get the update.

1 Like

does it work if you set preserveDrawingBuffer to false ?

like in this PG: https://playground.babylonjs.com/#RLBZPF#7

Still the same issue as video above in that PG with preserveDrawingBuffer: false

Ok I ll see what we can do :frowning:

this one ? https://playground.babylonjs.com/#RLBZPF#11 @br-matt and @robertoranon sorry for all the ping, trying out blindly… :frowning:

It’s no problem. Still the same issue however

If this helps, adding in DefaultRenderingPipeline fixes the artifact drag issue, but does weird things to the coloring. This is from the bug I reported here ShadowGenerator causing rendering artifacts in Safari 15.4

Please try to disable “WebGL via Metal” option

That did the trick @Deltakosh !

1 Like

This bug in WebKit is killing my new home page: https://www.binpar.com/en

To tell all users to disable WebGL via Metal will not be an option.

1 Like

I can’t agree more

We are unfortunately hand tied. This is down below the browser and we did not find a single workaround so far

It is a problem across the board (3js, playcanvas or even Unity are on the same boat)

Disabling antialiasing seems to also work as a workaround https://playground.babylonjs.com/#RLBZPF#18

1 Like

Is there a reliable way to detect if a browser will have this problem, and so turn antialiasing off conditionally?

You would need to probe the user agent and detect that it is a 15.4 version then maybe the webgl debug info would let you know if it is M1 or not but I do not think so… Fortunately I hope they will fix it soon as it looks like it might already be top of tree on webkit

Thanks! We’ll do that for now. Hope the webkit fix will come out soon

1 Like

Folks on bugzilla are confirming this is fixed for next release :tada: