Babylon.js does not work on iOS 14.2 Safari browser


  • Bug repro on playground:
  • Expected result: page loads
  • Current result: page doesn’t load with Error A problem repeatedly occurred on


  • I am on iOS 14.2 (iOS beta version). Need to enroll Apple beta program to upgrade iOS to 14.2 as of now
  • This is affecting our product which uses Babylon as well. But since Babylon playground also doesn’t work on iOS 14.2, getting the site work should probably help with external usage of Babylon.js as well

1 Like

I got that on a completely unrelated page on an iPad. Try again after a restart.

I got that on a completely unrelated page on an iPad. Try again after a restart.

What? that is irrelevant to this.

I am able to reproduce the issue posted. This only happens as of 14.2 beta. It happens with all projects with babylon

1 Like

Sounds more like a ios bug?

Assuming your PG loads 4.2 beta version of babylon (default), and your product uses the stable 4.1.
If these asumptions are correct, i don’t see how it can be a babylon bug


I am able to see WebGLRenderingContext and supported extensions in the safari browser console with iOS 14.2 beta. See below screenshot. Seems like WebGL is supported in the safari browser. Any idea if it’s missing any supported extension or not functioning well?

And when I go to on the 14.2 beta safari browser, I can load the page fine and see the spinning cube

as I don’t have (and don’t plan to install) ios14.2 beta I would need your help
First my guess is that is is linked to a safari issue so you should post to their forum if you want a quick fix

second: can you debug it and see what is on the console? any errors?

There is not much in the console. See below screenshot. The 404 request there shows up in iOS14 safari browser as well where babylon playground loads fine, so might just be a red herring. No failed request in the Network tab neither.

No obvious error info anywhere and it makes it hard to know what’s going on

that is really weird. You should at least have one message like “babylon.js v4.2…”

1 Like

Right I was expecting to see the babylon version message as well but it did not show up. When loading babylon playground, the browser reloaded twice and the the page crashed with a vague error A problem repeatedly occurred on .... I put the whole screen recording and console output together for reference, see below.

The babylon playground intro/loading page did however show up before the page crashed, according to the screen recording

I almost sure this is something wrong with ios and webgl2

For the last week or two we’ve been getting reports of iOS issues, with the context being lost suddenly, and then being unable to recover. I was able to reproduce it once on 14.0, WebGL 1 on BJS 4.1. I can’t say for sure it is related, but we didn’t get these reports previously.

1 Like

I turned off the webgl2 support on ios14 to see if this helps

1 Like

Is this supposed to help with the babylon playground issue we are seeing in Safari 14.2?

1 Like

To test out whether it’s a WebGL issue, I tried Three.JS examples too on iOS14.2 Safari browser. URL: three.js examples

iOS14.2 Safari did not crash for Three.JS example.

Can you try again? I removed the webgl2 support for safari (You will need to clean the cache)

1 Like

@Deltakosh - Thanks for response - should I wait until playground version ( gets updated to another version other than 4.2.0-beta6 ? I just tried going to the site, after deleting caches, but still Safari crashed.

beta 6 is already the one with no webgl2 support :frowning:

@Cedric do you have a device with 14.2 beta?

Maybe wrapping the internal pg code in a big try/catch could give a clue?