Maya Exporter / Draco Compression

I have a question about Draco Compression. It used to work fine but recently i got the notification
“glTF-pipeline module not found”
So I downloaded the newest version of node.js and installed the gltf-pipeline again, but i still get that message.
Now, the strange thing is, when I’m exporting a simple sphere it seems to work but when I’m trying to export my crane it will not be compressed…

Unfortunately, I’m not allowed to share that crane at the moment, but maybe you have any suggestions regardless?

Thanks in advance

1 Like

Pinging @kcoley to see if he can be kind enough to help

@Clms I followed the docs here: 3DSMax to glTF - Babylon.js Documentation

and ran npm install -g gltf-pipeline and launched 3ds Max. I was able to export using Draco compression without the error you received. If the docs don’t work for you, can you make a sample scene that repros the issue?

Hi, I’m using Maya but I guess the Maya exporter is not much different to 3DSMax.
I was trying to repro that issue, but unfortunately I can’t.
It is working until i try to export the crane model and I’m not allowed to share that.
…maybe it is an issue with the geometry i got from our constructions departement.

I’ll probably have to check that model piece by piece… but I was wondering if there’s a way to add Draco Compression after the export?

When I’m loading my exported .glb file into the babylon sandbox, I also get this Error:

“Indices for indexed attribute semantic ‘TEXCOORD’ must start with 0 and be continuous”

But it appears like this Error doesn’t have any impact on the model.

@Clms sorry I missed the Maya part, though I believe the process is the same for Maya and 3Ds Max. You can also use glTF toolkit and apply Draco compression with this project: GitHub - Microsoft/glTF-Toolkit: A collection of tools for modifying and optimizing glTF assets

Unfortunately, I’m not sure if the texture coordinate indexing issue is related or not


Thank you. I’ll try that toolkit.

The texture coordinate errors have been related to some wrong UVs. I was able to purge them.

1 Like

I noticed recently that Draco is also working as long as i export as *.glTF.
I’d rather export as *.glb, but whenever i try i’ll get that “glTF-pipeline module not found” notification.

I’ve tried to use the glTF-Toolkit, but i’d rather have Draco applied directly on export, so i’ll keep trying to repro this issue in a file that i can share.
It could also be more an issue of that glTF-pipeline than the Babylon Exporter.

did you make it working? any luck?

Yup it should be all good now.