Scene freezes completely upon mouse button up (Desktop Safari only) TypeError


I tested all sorts of browsers, desktop and mobile, this issue seems to be Mac Safari exclusive (also in different Safari versions).
Only on there after any mouse button UP a TypeError gets thrown:

TypeError: undefined is not an object (evaluating 'e[a.c.MouseWheelX]=0')
    (anonymous function) - babylon.js:91339
    (anonymous function) - babylon.js:3152:168
    (anonymous function) - babylon.js:5817
    (anonymous function) - babylon.js:5795:108
    (anonymous function)

Meaning you can press, drag to look and everything works as expected, but upon releasing the scene freezes and you can’t interact anymore. Interestingly enough when I do it during loading in of my assets, apparently the loading continues (as seen through the console), while the scene is frozen so you don’t see any change. Maybe this means just the rendering is stuck?
I’m not really a web developer so I don’t really understand what’s happening in your code at the error throwing section. Hopefully you can help me. :v:

Edit: Test playground

Although my real playground is a lot bigger, this smaller playground throws the same error:

Note: It also throws an error if it’s hosted locally.

EditEdit: It also freezes in the standard playground, so nothing to do with my playground I guess.

Pinging @PolygonalSun

@PolygonalSun would be amazing if you can have a look shortly has I am pretty scared we have a regression here. Let me know if you can not.

Last night, I merged a PR that should fix this issue: DeviceInputSystem - Fix issue where mouse is deregistered on MacOS by PolygonalSun · Pull Request #10458 · BabylonJS/Babylon.js (


It works now, no more errors!
Had to clear cache like twice before it worked.

Thank you!

@PolygonalSun I’d love to test this out for the other iOS freeze issue :pray: Is there any way we can get a new npm build soon ? I could also test it on the PG if there is a way to test the nightly there.