Trouble Getting a Rigging to export from Blender

So I am just trying to see if I can get a basic rigging done in blender so I can get a very specific rid done for work purposes (this is not that rig).

But when I export from blender and as a babylon file I do not get any skeletons once imported into my scene with:
BABYLON.SceneLoader.ImportMesh(null, “./”, “test.babylon”, scene, function (meshes, particles, skeletons) {

The mesh appears, and in the babylon file I see the skeletons but in the scene and with all console reports or debug stuff I see no skeletons?
skeletons: Array(0)

Here is a screenshot from blender. Keep in mind I know NOTHING about blender and am huffing and puffing that I cant do it in c4d yet… but anyways please someone help?

I don’t use “ImportMesh”, I use Append to load characters but what happens if you try something like this in your code, Pryme?:

skeleton = newScene.getSkeletonById(0);

And by the way, looking at your image from Blender, the meshes are not parented to the armature -see they are all above the “root”, . and as I can not see the scale and rotation of anything (meshes and skeleton) in the image - you may have issues there.

cheers, gryff :slight_smile:

1 Like

I got a null response. I also tried to parent it and export it and I ended up with a null response as well.

I have not painted any weights yet or anything like that so could that be the reason?

To answer the “weight” question. Did you parent it with “automatic weights”? If you did they should work pretty well.

Post the blend file, and let me try this evening.

cheers, gryff :slight_smile:

Thanks because I know nothing about blender!

Ill post the file when I get home from lunch.

FYI, the parenting restriction was removed a long time ago. Yes, in order to get the automatic weights, you need to parent. But after that you can un-parent, keeping transforms, which preserves the modifier.

This is useful, if you wish to parent a mesh with an armature to something else. Just check that the armature modifier is still on the mesh.

1 Like

@JCPalmer so what would cause the skeleton to appear in the Babylon file but not in the Babylon scene?

When you use importMesh, only the things needed for that mesh are loaded. If for some reason in the .babylon file the mesh were not assigned a skeleton, then it would not be loaded.

As far as for reasons it would not be assigned on export, the most likely is there is no armature modifier assigned to the mesh. One quick way of know that is: “Does your animation runs?”. If so then there is a modifier on the mesh.


@JCPalmer And that I did not know Jeff. You learn something every day :slight_smile:

cheers, gryff :slight_smile:

and having them assigned to weights fixed it!

thank you @JCPalmer. At least I know how to do rigging in blender now… its kinda cool software but a lot of the tools are very counterintuitive to what I am used to.

Actually, the strange UI is part of what Blender addresses in the 2.80 version. Much less reliant on key short cuts, and a more standard use of the mouse, with much on the right click context menu which was added.

If you plan on doing anything in Blender, I suggest moving to 2.80, which is very stable, if not production. I have personally spent a cumulative hour swearing trying to find stuff, but have learned right click is usually the answer. Putting anything into a prior version is a waste, especially since, old .blend files can be tricky to get to 2.80.

The z-up part can be ignored, as the exporter takes care of that for you.


Word, I am on it. Gonna look for 2.8 cause I am running 2.7 something.

Yeah, Blender was harder to wrap my head around then ZBrush and that is saying something…

1 Like