Typescript playgrounds broken?

Anyone else getting this today?

Cant find namespace BABYLON

yeah ! Same here,

I had the same 2 days ago but it seems that it’s not consistent. It was gone after a reload / back and forth to JS. Right now both JS and TS are ok on my side.

I don’t know if it can be related but I reported as well this bug yesterday, where some error happens in a random maner I can’t figure out the precise reproduction pattern

I confirmed it was broken yesterday.
The last time I checked it was around Monday.
And it’s still the same

@Deltakosh any idea what’s going on with this? :heart:

I’m on vacation but added @RaananW

1 Like

This has been fixed yesterday already. Are you all still seeing the issue? Does a hard reload solve it?

still not working
(browser reload, hard cache clear reload, playground reload)


Works fine on my side :thinking:

[EDIT] : Possible usefull info :

  • :white_check_mark: Above working version is Linux Ubuntu 22.04 (Chrome 124.0.6367.118 (Official Build) (64-bit))
  • :red_square: Indeed I’m having the issue on Windows 10 PC (Chrome 123.0.6312.88 (Official Build) (64 bits)) but it’s a 10 y.o. laptop…

I tried updating the version just in case.
(windows pc 10)
not work chrome 124.0.6367.202
edge is okay

On Windows 10 (build 19045.4291) doesn’t work for Chrome, Edge and Firefox

Sorry, could you check again, forcing your cache to clear? There was a pushed PR that caused the typings to be a little off. I patched it yesterday, but the playground was built again, eliminating my temp patch. I am planning on tackle it full-force on monday, but until then I expect the playground to work as expected.

Mines working on a forced clear and hard reload now.

1 Like

Now it works for me, too. I tried to disable the cache via DevTools a couple of hours ago and it didn’t work, but now it suddenly works. Pretty strange :joy:

Next time instead of just disabling the cache open your dev console then right click on the refresh button you will get more options

Doing and empty cache and hard reload sometimes works way better then expected even if you are not holding onto a cache.

1 Like