Using node material with default pipeline DoF


I’m trying to create a set of cubes floating around that have a custom node material applied to them and the whole scene uses the Default rendering pipeline. When I set pipeline to use depth of field, the depth map that gets rendered doesn’t show the boxes. If on the other hand I swap the material to Standardmaterial, PBR or some other then it works.

Does the custom node material support depthmaps or am I missing some option to enable it?

Do you mind providing a repro in the playground? THis is something we should be able to fix

Sure, I’ll do one first thing tomorrow morning.

Here’s an example of the issue with very basic node material and the scene used in depth of field example.

Ok here is your fix:
Node material with depth of field | Babylon.js Playground

basically I forced your node materials with mat.ignoreAlpha = true (because else meshes are flagged as transparent and thus do not write in the depth buffer and then dof does not work)

Thanks! That worked.