Videotextures get stuck in WebXR immersive mode in safari in Apple VisionOS simulator


I’m trying out to use a video texture in WebXR for safari in the Apple VisionOS simulator, but for some reason the video get stuck when the immersive mode is enabled. The video continues when immersive mode is disabled. I just recorded a video showing it.

This is the repro playground:

The other issue you can see in this video (washed out colors) has been reported in this post:

1 Like

cc @RaananW

Thanks! We will need to debug that. It seems like the video element has a stop event triggered when entering XR. I wonder if triggering an XR select (i.e. tap from hands in the emulator) plays the video. cc @Cedric, in case you have the time to test


Yes! I tried to manually play the video after entering XR and it worked! Thank you! :smiley:

In this example the video will be played again 2 seconds after entering XR.


might be safari’s restrictions on video playback. good to know that it does play correctly!